How to turn the "mod_rewrite" off

Find all the help you need on the script Arfooo Directory.
Please refer any bugs found.

Moderator: effi

How to turn the "mod_rewrite" off

Postby jasonc » Thu May 01, 2008 7:49 am

Hello

I love the looks and feel of this script, but Is it possible to use this script on IIS? Because IIS does not have mod_rewrite.

For example when I click the "Management" link which is linked to "webmaster-management.html", it shows not found, and i guess this is because IIS does not have mod_rewrite. (All the files are correctly placed in my server.)

Does anyone have any clue about using this script on NON mod-rewrite server?

Thanks in advance,

JasonC
jasonc
 
Posts: 3
Joined: Thu May 01, 2008 7:38 am

Re: How to turn the "mod_rewrite" off

Postby Arf » Fri May 02, 2008 7:49 pm

Hi,
Do you have install the script or the script is not install for the moment ?
Arf
Site Admin
 
Posts: 212
Joined: Fri Mar 14, 2008 6:51 pm

Re: How to turn the "mod_rewrite" off

Postby jasonc » Sat May 03, 2008 4:54 am

Hello, Thanks for the reply.

I already installed the whole script.
jasonc
 
Posts: 3
Joined: Thu May 01, 2008 7:38 am

Re: How to turn the "mod_rewrite" off

Postby Arf » Sat May 03, 2008 7:30 am

Hello,
With pleasure for the answer :)

So you have to go into your database with phpmyadmin.
We must go to the table "settings" and find
"urlRewriting."
We must change "1" to "0".

Arf
Arf
Site Admin
 
Posts: 212
Joined: Fri Mar 14, 2008 6:51 pm

Re: How to turn the "mod_rewrite" off

Postby jasonc » Sun May 04, 2008 11:45 pm

Dear Arf,

Again thank you very much for your big help.

I have made a change to "urlRewriting" setting (to 0), restarted the server (just in case) and tried again. Something have changed, but I still cannot manage to access to anywhere from top page.

For example, "Management" is linked to
"http://(my server)/arfooo/index.php/webmaster/manage"

Do you know any more details about why this happens?

Thanks in advance

Jason C.
jasonc
 
Posts: 3
Joined: Thu May 01, 2008 7:38 am

Re: How to turn the "mod_rewrite" off

Postby Arf » Mon May 05, 2008 1:13 pm

Hi,
Have you removed the htaccess?
What exactly is the problem?

I just try again in the mod_rewrite disabling and removing the htaccess and I have no problem.

It is true that I have tested with wamp but normally you should have no problem because the mod_rewrite is not used at all when it comes to 0.

If you still have problems, tell me with details of preferences :)

Thank you.
Arf
Site Admin
 
Posts: 212
Joined: Fri Mar 14, 2008 6:51 pm

Re: How to turn the "mod_rewrite" off

Postby happyhardik » Tue Jan 20, 2009 12:39 pm

Hi,

I have been facing the same problem.

My server cofiguration is IIS7, Windows Server.
PHP 5, MySQL 4.

The directory installed perfectly, but now I face this error when try to open it:
Code: Select all
Redirect Loop

Redirection limit for this URL exceeded.  Unable to load the requested page.  This may be caused by cookies that are blocked.


I am using firefox.
I tried to open this url on my server:
http://(my server)/arfooo/index.php/webmaster/manage
and it worked, but if I try to click on a link above error occurs, as well as if I try to open the directory link: http://(my server)/arfoo/ than the same error occurs.

I set the urlRewriting field to 0 in setting table, also deleted the .htaccess file.
Please help me, I like the script and I want to use..
Ask me if you want my server url.

Many thanks,
happyhardik.
happyhardik
 
Posts: 2
Joined: Tue Jan 20, 2009 12:29 pm

Re: How to turn the "mod_rewrite" off

Postby happyhardik » Tue Jan 20, 2009 12:47 pm

Hi,

I have found out that if I open it using a link like this:
http://(my server)/arfooo/index.php/webmaster/manage
it works.

I can access all the pages, but cannot open the home page, it fires the above error.
Please tell me how can I solve this.

Thanks, in advance.

Thanks,
happyhardik.
happyhardik
 
Posts: 2
Joined: Tue Jan 20, 2009 12:29 pm

Re: How to turn the "mod_rewrite" off

Postby Maxy » Tue Mar 15, 2011 2:12 am

I'm trying to install a script and requirements say that the mod_rewrite must be off. The only way you can disable mod_rewrite is to change the server's settings.
Maxy
 
Posts: 4
Joined: Tue Mar 15, 2011 2:03 am


Return to Installation, support and bug reports

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

 
Copyright © arfooo.net  2007 - 2010  -  All rights reserved.
Arfooo website group: petites annonces gratuites   voyance en direct - tirage tarot   Consultant en référencement
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group | phpBB SEO
cron